专业提供IPLC、MPLS专线、SD-WAN、IEPL、海外IDC、云专线等技术方案。
咨询热线:400-028-9798

海外专线-国际带宽-微云网络

IPLC

Segment Routing之static-sr-mpls:静态配置Segment配置

发布时间:2021-07-18 10:08:52作者:铁军哥阅读:0

[导读]: 组网需求 1、设备VSR1、VSR2、VSR3、VSR4和VSR5运行IS-IS协议,已OK。 2、使用静态SRLSP建立一条VSR1到VSR4的MPLS TE隧道,实现两个IP网络通过MPLS TE隧道传输数据流量。静态SRLSP经过三个段,#1段:
组网需求

1、设备VSR1、VSR2、VSR3、VSR4和VSR5运行IS-IS协议,已OK。

2、使用静态SRLSP建立一条VSR1到VSR4的MPLS TE隧道,实现两个IP网络通过MPLS TE隧道传输数据流量。静态SRLSP经过三个段,#1段:VSR1到VSR2的邻接段,#2段:VSR2到VSR3的邻接段,#3段:VSR3到VSR4的邻接段。

3、使用静态SRLSP建立一条VSR1到VSR5的MPLS TE隧道,实现两个IP网络通过MPLS TE隧道传输数据流量。静态SRLSP经过三个段,#1段:VSR1到VSR2的邻接段,#2段:VSR2到VSR3的前缀段,#3段:VSR3到VSR5的邻接段。

具体组网情况参照组网图及接口地址分配表。

实验环境

VMWare ESXi 6.7.0(ProLiant DL360 Gen9,48核心,128G内存)

H3C VSR1000(Version 7.1.064, Release 0621P18,4核心,8G内存)

Windows 7旗舰版(测试用虚拟机,8核心,16G内存)

组网图

静态配置Segment组网图如下。

Segment Routing之static-sr-mpls:静态配置Segment配置

设备的链路连接、接口及接口地址配置情况如下表:

Segment Routing之static-sr-mpls:静态配置Segment配置

配置步骤

注意到VSR1到VSR4和VSR5之间转发路径的差异,在于#2段的分段类型不同,一个是邻接段,也是各段普遍使用的方式;另一个是前缀段,仅此一段。

邻接类型的段,Adjacency Segment,为节点的不同邻接链路分别分配SID。

前缀类型的段,Prefix Segment,按目的IP地址前缀为网络的节点分配SID并建立转发表项。

在静态配置Segment之前,需完成以下任务:

1、在参与MPLS转发的各个节点和接口上开启MPLS能力;

2、确定静态SRLSP的头节点、中间节点和尾节点;

3、规划每个节点到下一跳的邻接路径的入标签值,规划每个节点的前缀路径标签值。需要注意的是,静态SRLSP与静态LSP、静态CRLSP使用相同的标签空间,在同一台设备上静态SRLSP、静态CRLSP和静态LSP的入标签不能相同。

1、配置MPLS

首先配置路由器的LSR ID,在各个节点和接口上开启MPLS能力和MPLS TE能力。

VSR1

#

mpls lsr-id 1.1.1.1

#

mpls te

#

interface GigabitEthernet2/0

ip address 12.1.1.1 255.255.255.0

isis enable 1

mpls enable

VSR2

#

mpls lsr-id 2.2.2.2

#

mpls te

#

interface GigabitEthernet2/0

ip address 12.1.1.2 255.255.255.0

isis enable 1

mpls enable

#

interface GigabitEthernet3/0

ip address 23.1.1.2 255.255.255.0

isis enable 1

mpls enable

#

interface GigabitEthernet4/0

ip address 32.1.1.2 255.255.255.0

isis enable 1

mpls enable

VSR3

#

mpls lsr-id 3.3.3.3

#

mpls te

#

interface GigabitEthernet2/0

ip address 23.1.1.3 255.255.255.0

isis enable 1

mpls enable

#

interface GigabitEthernet3/0

ip address 32.1.1.3 255.255.255.0

isis enable 1

mpls enable

#

interface GigabitEthernet4/0

ip address 34.1.1.3 255.255.255.0

isis enable 1

mpls enable

#

interface GigabitEthernet5/0

ip address 35.1.1.3 255.255.255.0

isis enable 1

mpls enable

VSR4

#

mpls lsr-id 4.4.4.4

#

mpls te

#

interface GigabitEthernet2/0

ip address 34.1.1.4 255.255.255.0

isis enable 1

mpls enable

VSR5

#

mpls lsr-id 5.5.5.5

#

mpls te

#

interface GigabitEthernet2/0

ip address 35.1.1.5 255.255.255.0

isis enable 1

mpls enable

2、配置节点的邻接路径标签和前缀路径标签

配置VSR1的邻接标签,为下一跳地址12.1.1.2绑定标签16。

#

static-sr-mpls adjacency adj1 in-label 16 nexthop 12.1.1.2

配置VSR2的邻接标签,为下一跳地址32.1.1.3绑定标签21。

#

static-sr-mpls adjacency adj2 in-label 21 nexthop 32.1.1.3

配置VSR2的前缀标签,为下一跳地址32.1.1.3、35.1.1.3绑定相同的前缀路径名称、入标签16000、出标签16001,在VSR2和VSR3之间形成负载分担。

#

static-sr-mpls prefix pre1 destination 5.5.5.5 32 in-label 16000 nexthop 32.1.1.3 out-label 16001

static-sr-mpls prefix pre1 destination 5.5.5.5 32 in-label 16000 nexthop 35.1.1.3 out-label 16001

配置VSR3的邻接标签,为下一跳地址192.168.14.1、192.168.15.1分别绑定标签30、31。

#

static-sr-mpls adjacency adj1 in-label 30 nexthop 192.168.14.1

static-sr-mpls adjacency adj2 in-label 31 nexthop 192.168.15.1

配置VSR3的前缀标签,为目的地址5.5.5.5绑定标签16001。

#

static-sr-mpls prefix pre1 destination 5.5.5.5 32 in-label 16001

3、创建静态SRLSP

配置VSR1为静态SRLSP的头节点,srlsp1出标签栈为[16,21,30],建立到VSR4的静态SRLSP。

#

static-sr-mpls lsp srlsp1 out-label 16 21 30

配置VSR1为静态SRLSP的头节点,srlsp2的出标签栈为[16,16000,31],建立到VSR5的静态SRLSP。

#

static-sr-mpls lsp srlsp2 out-label 16 16000 31

4、配置MPLS TE隧道

在VSR1上配置到VSR4的MPLS TE隧道Tunnel14:目的地址为VSR4的LSR ID(4.4.4.4);采用静态SRLSP建立MPLS TE隧道,引用的SRLSP为srlsp1。

#

interface Tunnel14 mode mpls-te

ip address 14.1.1.1 255.255.255.0

mpls te signaling static

mpls te static-sr-mpls srlsp1

destination 4.4.4.4

在VSR1上配置到VSR5的MPLS TE隧道Tunnel15:目的地址为VSR5的LSR ID(5.5.5.5);采用静态SRLSP建立MPLS TE隧道,引用的SRLSP为srlsp2。

#

interface Tunnel15 mode mpls-te

ip address 15.1.1.1 255.255.255.0

mpls te signaling static

mpls te static-sr-mpls srlsp2

destination 5.5.5.5

5、配置静态路由使流量沿MPLS TE隧道转发

在VSR1上配置静态路由,使得到达网络34.1.2.0/24的流量通过MPLS TE隧道接口Tunnel14转发,到达网络35.1.2.0/24的流量通过MPLS TE隧道接口Tunnel15转发。

#

ip route-static 34.1.1.0 24 Tunnel14 preference 1

ip route-static 35.1.1.0 24 Tunnel15 preference 1

验证配置

以VSR1为例,查看路由器MPLS TE隧道的建立情况。

display mpls te tunnel-interface

Segment Routing之static-sr-mpls:静态配置Segment配置

在VSR1查看静态SRLSP的建立情况

display mpls lsp

Segment Routing之static-sr-mpls:静态配置Segment配置

dis mpls static-sr-mpls lsp

Segment Routing之static-sr-mpls:静态配置Segment配置

在VSR2查看静态SRLSP的建立情况

Segment Routing之static-sr-mpls:静态配置Segment配置

在VSR3查看静态SRLSP的建立情况

Segment Routing之static-sr-mpls:静态配置Segment配置

查看系统路由表。

Segment Routing之static-sr-mpls:静态配置Segment配置

在VSR1上带源地址192.168.11.1访问VSR4的192.168.14.1等地址验证连通性。

Segment Routing之static-sr-mpls:静态配置Segment配置

TTL跳数这里和正常转发是一样的,跟之前的隧道好像不太一样。在VSR1和VSR2互联链路上抓个包看一下。

Segment Routing之static-sr-mpls:静态配置Segment配置

再从VSR2和VSR3互联链路上抓个包看一下。

Segment Routing之static-sr-mpls:静态配置Segment配置

报文结构一点没变,看来是控制转发的,traceroute看一下。

Segment Routing之static-sr-mpls:静态配置Segment配置

还是可以看到第二跳是不一样的,说明确实可以控制报文转发路径。

总结

1、邻接段的入标签值,手册写的取值范围为16~10240,但是设备上可配置的是16~1023,有点出入;前缀段的入标签值,手册写的和设备上可配置的取值范围都是16000~24000,是一样的;

2、mpls-te类型的隧道不做报文的隧道封装,从配置上我们也可以看到,这个隧道仅在源端进行了配置,未在目的端进行配置,所以作用只是指导报文转发,不改变报文结构;

3、添加静态路由时,要注意IS-IS的优先级是15,设置的静态路由优先级要小于15,否则不生效;

4、当采用邻接段方式,静态配置标签转发表项时,设备为与邻接设备相连的链路静态分配入标签。该标签值只在本地有效,不同设备上的Adjacency SID可以相同;当采用前缀段方式,静态配置标签转发表项时,设备根据手工指定的入标签、出标签以及下一跳的对应关系形成本地的标签转发表项。结合配置也可以发现,邻接段方式表项有入标签和下一跳,而前缀段方式有入标签、下一跳和出标签,出标签一般配置为下一跳的SRGB基值+Index,如16001=16000+1;

5、正常来讲,当源节点接收到业务报文后,会为报文封装所经过路径上的标签信息,并通过SRLSP将报文转发给尾节点;尾节点从SRLSP接收到报文后,会剥离报文中的标签,根据原始报文的目的地址查找路由表进行报文转发。这就说明了为什么尾节点VSR4和VSR5不用配置,而源节点VSR1配置的不是出标签、而是入标签了。

以上就是Segment Routing之static-sr-mpls:静态配置Segment配置的介绍,Vecloud作为专业的网络服务商,我们有着丰富的海外专线解决方案,感兴趣的可以直接联系我们客服咨询。

免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系我们本站,我们会尽快处理。

标题:Segment Routing之static-sr-mpls:静态配置Segment配置

TAG标签:MPLS

地址:http://www.vecloud.com.cn/mplsvpn_line/312.html

上一篇:没有了
下一篇:没有了

常见问题

  • 为什么在中国访问国外的网络慢?

    因国情不同,中国的通信网络起步较晚,网络的环境相对较差,因此在访问国外网络的时候会出现访问国外网络慢的情况。而这种情况的产生不是单一的原因,还有很多因素。 1、国内

  • 香港服务器能备案吗?香港服务器怎么备案

    很多国内站长前期为了快速上线网站业务,都会使用国外服务器,一般以香港服务器居多。 在以前香港服务器确实是可以备案,但后来针

  • 为什么最近自建的VPN无法使用了

    最近很多网友及客户反馈,为什么这段时间使用的腾讯和阿里的服务器搭建的VPN不能使用了? 首先,我们要从大厂的服务源说起。根据《中国跨境数据通信产业自律公约》第六条要求,

  • MPLS专线是什么?详细分析MPLS专线的优点

    MPLS专线是什么?MPLS随着互联网的快速发展和企业业务和规模的不断发展,企业对自身网络的建设提出了越来越高的要求。越来越多的企业需要利用公共网络与各分公司建立私人网络,即虚拟私人网络。在所有的技术

  • 游戏服务器总被DDoS攻击,到底是为什么?

    一直都说游戏是受DDoS攻击的重灾区,游戏行业确实是DDoS攻击的热门目标,而且现在海外DDoS攻击真的很强大。 在腾讯安全发布的一份报告中,其表明游戏行业仍是DDoS的首要攻击目标。

  • MPLS专线主要有哪些特点和优势?

    IPLC是国际专用租赁电路,用作点对点专用线路。IPLC通常是TDM在许多客户中使用相同的电路。TDM性质要求使用CSU/DSU和路由器。通常,路由器包括CSU/DSU。最常用的路由器Cisco或Ad

  • 什么是MPLS?

    MPLS(Multi-ProtocolLabelSwitching)即多协议标记交换。是核心路由器利用含有边缘路由器在IP分组内提供的前向信息的标签(label)或标记(tag)实现网络层(3层)交换...

  • 公司用的Polycom卡顿延迟严重怎么解决?

    大多数导致Polycom卡顿延迟的原因是这几个 1、防火墙连接。 验证是否在防火墙打开了所需的 URL、IP 地址和端口可最大程度地减少不必要的故障排除。 2、企业办公路由器和计算机性能不

  • gotomeeting国外会议共享桌面卡顿如何解决

    公司总部在与分部进行gotomeeting国外会议时共享桌面卡顿,主要是因为公网有长城防火墙的存在,那么gotomeeting国外会议卡顿如何解决? Vecloud小编推荐Veloud gotomee...

  • 公司里的 webex视频会议经常卡顿怎么解决?

    国际版 Cisco webex视频会议卡顿一般是这几个原因造成。 1、企业办公计算机性能不足,造成打开缓慢;解决办法:重点升级计算机cpu和内存。 网 2、网络问题:由国外客户发起Cisco WebE