专业提供IPLC、MPLS专线、SD-WAN、IEPL、海外IDC、云专线等技术方案。
咨询热线:400-028-9798

海外专线-国际带宽-微云网络

IPLC

原来这才是网络地址转换NAT的重点

发布时间:2021-07-07 15:04:41作者:V小编阅读:0

[导读]: NAT NAT技术使得一个私有IP地址网络可以通过合法的公网IP连接到公网,同时将内部网络的IP地址隐藏起来不被外界发现,对内部网络设备起到保护的作用,同时,它还帮助网络可以超越地

NAT

NAT技术使得一个私有IP地址网络可以通过合法的公网IP连接到公网,同时将内部网络的IP地址隐藏起来不被外界发现,对内部网络设备起到保护的作用,同时,它还帮助网络可以超越地址的限制,合理地安排网络中的公有IP地址和私有IP地址的使用

原来这才是网络地址转换NAT的重点

NAT优缺点:

原来这才是网络地址转换NAT的重点

NAT术语:

原来这才是网络地址转换NAT的重点

NAT转换规则:

数据包从outside接口到inside接口,先转换后查路由

数据包从inside接口到outside接口,先查路由后转换

ip nat inside source是指把私网地址转换成公网地址

ip nat outside source是指把公网地址转换成私网地址

NAT转换顺序:

从inside到outside时转换源地址

访问8.8.8.8 源地址是192.168.1.1 被路由器转换成202.1.1.1的源地址出去

从outside到inside时转换目标地址

8.8.8.8 回包202.1.1.1,路由器查NAT表,目的地址被转换192.168.1.1

从outside到inside时转换源地址

203.2.1.1 访问 192.168.10.1源地址被路由器转换成192.168.20.1

从inside到outside时转换目标地址

192.168.10.1 回包192.168.20.1  路由器查NAT表,目的地址被转换203.2.1.1

静态NAT:

内部网络中的每个主机都被永久映射成外部网络中的某个合法的地址。静态NAT将部本地地址与内部全局地址进行一对一的转换。多用于服务器映射。静态映射是

原来这才是网络地址转换NAT的重点

R2配置示例:

ip nat inside source static 192.168.1.1 183.62.61.10       

//定义内部与公网地址一对一转换

ip route 0.0.0.0 0.0.0.0 183.62.61.2

interface f0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside                                                        

 //配置NAT入接口

interface f1/0

ip address 183.62.61.1 255.255.255.0

ip nat outside                                            

//配置NAT出接口!       

如果只是需要开放服务器的某些端口,则可使用静态端口映射,更加安全:

ip nat inside source static tcp 192.168.1.1 80 183.62.61.10 8080    

//将TCP协议80端口映射到8080

动态NAT:

是动态多对M的映射。动态NAT首先要定义合法地址池,然后采用动态分配的方法映射到内部网络。比如NAT地址池里有2个可用地址,但有3台主机需要上网,那么第Pc3就必须等到PC1或者PC2业务结束,把IP地址放回NAT地址之后才能使用。

原来这才是网络地址转换NAT的重点

R2配置示例:

ip nat pool ccna 183.62.61.20 183.62.61.30 netmask 255.255.255.0

//定义NAT地址池

access-list 1 permit 192.168.1.0 0.0.0.255

//定义访问控制列表

ip nat inside source list 1 pool ccna

 //将ACL与NAT地址池关联

ip route 0.0.0.0 0.0.0.0 183.62.61.2

interface f0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside

//配置NAT入接口

interface f1/0

ip address 183.62.61.1 255.255.255.0

ip nat outside

//配置NAT出接口

no shutdown

PAT/端口复用:

PAT则是把内部地址映射到外部网络IP地址的不同端口上,从而可以实现一对多的映射。由上面推论,PAT理论上可以同时支持(65535 - 1024) = 64511个会话连接。但是实际使用中由于设备性能和物理连接特性是不能达到的,Cisco的路由器NAT功能中每个公共IP最多能有效地支持大约4000个会话。PAT对于节省IP地址是最为有效的

原来这才是网络地址转换NAT的重点

R2配置示例:

access-list 1 permit 192.168.1.0 0.0.0.255

 //定义访问控制列表

ip nat inside source list 1 interface f1/0 overload

//将ACL与出接口匹配,并且是PAT方式

ip route 0.0.0.0 0.0.0.0 183.62.61.2

interface f0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside

//配置NAT入接口

interface f1/0

ip address 183.62.61.1 255.255.255.0

ip nat outside

//配置NAT出接口

no shutdown

NAT轮询:

外部用户对内部的真实主机访问时,NAT路由器会会截获得访问的数据包,把目的地址以以循环方式把目的地址转换为对应的真实主机上,以实现内网服务器的负载均衡

比如,内网有2台服务器,分别是 192.168.1.1、192.168.1.2

这2台服务器对公网开放的内容都是一样的,为了避免公网的访问流量对单台服务器造成的负荷,可将公网的流量以负载均衡的方式,让每台服务器承担二分之一的访问量

用户第一次访问将跳转到192.168.1.1这台服务器,第二次访问将跳转到192.168.1.2,以此轮询。

原来这才是网络地址转换NAT的重点

R2配置示例:

ip nat pool ccna 192.168.1.1 192.168.1.3 netmask 255.255.255.0 type rotary  

 //定义内网服务器流量分担地址,并且是轮询的方式

access-list 1 permit 183.62.61.1 0.0.0.0

 //定于被转换的地址,一般为路由器ouside 接口地址,也可为其他公网IP

ip nat inside destination list 1 pool ccna

// 关键!!将负载地址池与访问列表关联

ip route 0.0.0.0 0.0.0.0 183.62.61.2

interface f0/0

ip address 192.168.1.254 255.255.255.0

ip nat inside

//配置NAT入接口

interface f1/0

ip address 183.62.61.1 255.255.255.0

ip nat outside

 //配置NAT出接口

no shutdown!

免责声明:部分文章信息来源于网络以及网友投稿,本网站只负责对文章进行整理、排版、编辑,是出于传递 更多信息之目的,并不意味着赞同其观点或证实其内容的真实性,如本站文章和转稿涉及版权等问题,请作者在及时联系我们本站,我们会尽快处理。

标题:原来这才是网络地址转换NAT的重点

TAG标签:网络地址

地址:http://www.vecloud.com.cn/haiwaizhuanxian/301.html

常见问题

  • Polycom海外会议共享演示PPT掉线怎么解决?

    Polycom海外会议共享演示PPT掉线:Polycom视频会议国际版服务器在海外欧美等国家,主要原因是较差的Internet连接海外云服务器,音频和视频质量低,延迟。下载和上传缓慢主要是由于数据

  • AWS专线解决用户不能访问海外亚马逊

    中国用户正在访问海外AWS服务器访问缓慢,如何快速访问海外?AWS服务器?首先,为什么中国用户访问海外?AWS会变慢?总结可能有以下原因:1)利用互联网访问海外网络,由于中国网民众多,世界总出口有限,

  • 回国带宽服务器有哪些优点?

    提到香港服务器,许多人印象中的第一反应是cn2服务器,访问速度很快,但实际上除了cn2,此外,还有一种回国带宽服务器,近年来也很受用户欢迎,用户也很多。那么租用回国带宽服务器有什么好处呢?具体如下:1

  • 公司用的Cisco WebEx卡顿延迟严重怎么解决?

    导致Cisco WebEx卡顿延迟一般是这几个原因 1、防火墙连接。 验证是否在防火墙打开了所需的 URL、IP 地址和端口可最大程度地减少不必要的故障排除。 2、企业办公路由器和计算机性能不

  • 东南亚海外专线价格多少?

    要实现跨境网络访问,连接大陆与大陆以外的地区,需开通通信公司提供的企业专线,MPLS是当前主流的方案之一,那么东南亚海外专线价格多少?

  • 什么是香港国际专线,为什么走香港呢

    为什么我们现在一说国际专线习惯性的说走香港呢?香港与国际专线有什么关联呢? 大陆与海外的网络访问通过香港的互联网的我们称之为香港国际专线,大陆到香港的局域网专线我们也

  • 什么是EVPN?

    EVPN(Ethernet Virtual Private Network)是一种用于二层网络互联的VPN技术。EVPN技术采用类似于BGP/MPLS IP VPN的机制,通过扩展BGP协议,使用扩展...

  • RingCentral网络视频会议终端经常掉线什么原因

    RingCentral是一家企业云通信提供商,主要做视频会议产品。 RingCentral网络视频会议终端经常掉线的原因分析 一、硬件问题 电脑内存或者CPU型号老旧造成,可以尝试更换新设备 二、网络

  • 淘宝直播海外专线怎么开通?

    直播是淘宝全球采购市场非常重要的引流渠道;通过直播,用户可以增加对自己的信任,从而更好地促进转型。很多买家会在海外直播,但是网络卡顿影响用户观看,所以不能错过海外专线。这是什么?怎样添加?

  • 为什么最近自建的VPN无法使用了

    最近很多网友及客户反馈,为什么这段时间使用的腾讯和阿里的服务器搭建的VPN不能使用了? 首先,我们要从大厂的服务源说起。根据《中国跨境数据通信产业自律公约》第六条要求,